STScI Logo

Hubble Space Telescope
The APT FAQ & Bug List

E-mail us at help@stsci.edu if you do not understand the explanations on this page or you find a bug which is not listed. Note that there are documentation and instructional videos available.

Installation:

See the trouble shooting section at the end of each installation page:

General:

Questions: Bugs:

Editing:

Questions: Bugs:

Addresses for PIs and Co-Is:

Questions:

Phase I:

Questions: Bugs:

Updating an old Phase I Proposal:

Questions:

Phase II:

Questions: Bugs:

Orbit Planner:

Questions: Bugs:

Visit Planner:

Questions:
Bugs:

Aladin:

Questions: Bugs:

Bright Object Tool:

Questions:

General:

Why do I get the message, "Unable to locate the application's 'main' class."?

Under unix if you attempt to run APT remotely and do not have your DISPLAY variable set correctly, you will get this message:

Unable to locate the application' 'edu.stsci.hst.apt.controller.HstAptController' must be public and have a 'public static void main(String[])' method.

Do I have to be connected to the Internet while using APT?

For the most part, you can use APT without any Internet connection. You will only need a connection during submission, for Phase I address lookup, for a few of the help web pages, and for certain tool functions such as catalog overlays in Aladin. When you first start APT, it will check and display a message if there is a newer version of APT available. If you are not connected at the time, this check is not done.

Why is my proposal saved in a subdirectory?

APT will save proposal information in a sub-directory if the user preference is set to do so. You can set the preference by going to Edit>Preferences. Note that in Phase II mode, there are many support files that will be created and stored in the same directory with the proposal so we generally recommend a separate directory.

Why does it take so long to open my proposal?

Proposal information is validated when it is read in from the proposal file.In cases where there are a large number of observations defined this validation can take several minutes, especially on slower machines. During the proposal open and validation, an activity bar will display to show the progress.

Why won't my proposal open in APT?

If you cut and pasted from an e-mail message you may have a blank line at the top of the file. Please ensure the first line starts with "<?xml". If this was not the problem, please do not start from scratch. We quite likely will be able to fix the problem. Send e-mail to help@stsci.edu.

Where did the file go when I chose to print to file from the Visit Planner or Help print option?

If you print to file while in the Help or the Visit Planner, the file is written by default to a directory where the code was installed. Instead of merely giving a file name, fully specify the path where you want the file to be saved.

Random pop up dialog boxes only have a title bar on Linux with KDE.

Workaround: So far we have only seen this symptom on RHEL 5 machines running the KDE windowing system. The workaround is to use the GNOME windows system while running APT. Please let us know if you have this problem and tell us the version of Linux you are running. (65922)

Editing:

How do I delete, cut/copy&paste and rearrange things in APT?

In the Hierarchical Editor (the tree like view on the left hand side) you can highlight an entry and then delete it using Edit>Delete from the menu above (or by right clicking the entry and selecting Delete from the context sensitive menu). If you would like to move an entry within the list, you can use the Cut and Paste options from the menu or you can drag and drop.

You can select multiple entries by control clicking on several, or shift clicking at the top and bottom of a range of entries to be selected.Then you can use the cut and paste (or copy and paste) options under the Edit menu to move or copy the entries. (Drag and drop will not work for multiple entries.)

For more information please see the video called Editing with the Tree Editor.

Why is APT beeping at me instead of responding to what I click on?

The most likely reason is that a pop up box has been lost behind another window. Minimize all your windows and you will probably find it.

How do I save changes I make in a pop-up dialog?

Some pop-up dialogs that are displayed for the purpose of editing proposal fields (e.g. POS TARGS from the mini-spreadsheet) do not have a labeled button to close the dialog and save changes. To close the dialog and save changes simply close the window.

Why is APT suddenly taking a very long time to respond to simple changes?

You are probably having memory problems. Click on Help>Show Memory Monitor>GC (garbage collect) and then save your proposal and exit APT. Please see the APT Memory Issues page for more details.

Why doesn't cntl-click work as described in the documentation on my Mac?

On a Mac you should use apple-click in place of cntl-click for multiselecting individual items. (There are two other functional differences on the Mac. The Preferences and the Quit options are under a menu called "APT".)

Why can't I edit my proposal when I first open it?

Open Windows is not being maintained so it doesn't handle Java well. Most of the problems we have seen are cosmetic, but if you find you cannot work around a problem, try CDE instead. The most confusing one is that when you first open a proposal you cannot edit any field until you touch a scroll bar.

The tree outline of the proposal on the left hand side of APT GUI becomes filled with empty lines.

Workaround: This problem appears sporatically, but is more common when you are running APT remotely. It is benign and usually fixed by opening and closing folders in the tree. (54274)

How do I give STScI my new address information?

You can reach the STScI address web page using the "Update This Address" button in APT. Your changes will take effect right away (simply redo the lookup in APT). The exception is changes to name and e-mail addresses which are confirmed via e-mail before going into affect as a security measure. If you no longer have access to the e-mail address we have, please write to help@stsci.edu.

What if I am not in the STScI database yet?

Enter part of your name and hit return. If you are not in the resulting list you can reach the STScI address web page with the "Add a New Investigator" button. After adding a new investigator to the database please redo the lookup in APT.

Why can't I type in a name or get "Unable to contact the STScI server"?

Depending on your institution's computer security measures (firewalls, blocked ports, etc.), you may initially have trouble retrieving investigator addresses from our database. Since it would be best to discover and fix any communication problems well before the Phase I deadline, please follow these steps to diagnose and fix communication problems.

How can I search again for the same name?

If you searched for "smith" but then chose the wrong Smith, simply click on the lookup button next to the Last Name field.

Phase I:

Why can't I look up investigator addresses or submit?

Depending on your institution's computer security measures (firewalls, blocked ports, etc.), you may initially have trouble while using APT. This could include:

Since it would be best to discover any communication problems well before the Phase I deadline, here are the steps to diagnose and fix communication problems.

How do I share Phase I proposal information with my colleagues?

There are several ways to share your Phase I proposal with your colleagues depending on whether you want them to simply provide comments or actually edit the proposal. For instance, you can:

How can I create a second similar proposal from a submitted proposal?

When you open a previously submitted proposal you see the proposal number it was assigned when it was submitted. If you would like to start a new proposal starting with the old one as a template, go to the Submit Tool and click on "Clear ID#".

Why do I get an error when I try to create my PDF Preview?

When trying to create the PDF Preview a few people get an error like: An error occurred while trying to create a concatenated PDF file from. Make sure all files that are being concatenated are PDF files. ERROR: trailer not found. Workaround: If you generated your pdf attachment using LaTeX, it is sometimes necessary to open and re-save the resulting pdf using another program such as Adobe Reader or Apple's Preview. (73653)

Why are there problems with my combined APT proposal (e.g. attachment blank or math symbols missing)?

Symptom: You start with the LaTeX template for your scientific justification. Then you convert it to PDF. This looks and prints fine. But after you combine the scientific justification with the coverpage information you typed into APT, the resulting PDF file isn't right. It may look fine on the screen, but when printed, some or all of the text is missing (some people lose all the text, some just lose the math symbols). Not everyone has this problem, it depends on exactly how you converted to PDF.

Explanation 1: The explanations below are old and may no longer affect many people. But we did have a user this year (Cycle 22) report a similar problem. (The scientific justification was blank in the combined PDF.) The workaround is to resave your scientific justification attachment using another program such as Adobe Reader or Apple's Preview. (77476)

Explanation 2 (old): When APT merges the scientific justification with the rest of the proposal information, the result is a single PDF Version 1.4 file (regardless of whether your PDF file was 1.4 or 1.3). The resulting PDF 1.4 file is only fully compatible for printing with Acrobat 5.0 or higher (APT uses your local copy of Acrobat for display and printing). Note that some people have been able to work around the problem by embedding fonts or using ps2pdf13, but this has not worked for everyone.

Solution 2: Even though you can't print your complete APT proposal using your local Acrobat 3 or 4, we will be able to print it here for the TAC using Acrobat 5. If you want to print the complete proposal as the TAC will see it, download the free Acrobat Reader:

http://www.adobe.com/products/acrobat/readstep2.html

Then use the File>Export option to save the PDF file and print it using the Acrobat Reader.

Alternative Solution 2: Note that on Solaris and Linux APT's PDF Preview tool uses "acroread" to launch the PDF viewer. If "acroread" as defined on your system is earlier than Acrobat 5, you can redefine "acroread" for yourself to point towards a later version installed elsewhere on your system.

Explanation 3 (old): We have had reports from Mac users of attachments that started out as LaTeX files having missing math symbols in the printout as well as on screen even if the viewer is Acrobat Reader 5 or higher. The issue here appears to be the Apple Preview tool. If you use Apple Preview as your default PDF viewer then APT will use it when you press the PDF Preview button in APT. If you then save a PDF file from Apple Preview you will not see the problem in your own copy of the combined PDF, but anyone you give it to who does not have Apple Preview will have problems reading your draft. Please note that the problem here is only with the draft you create with APT's PDF Preview for sending around. Apple Preview is not used in the submission process.

Solution 3: There are two options for creating readable drafts for your Co-Is. You could change your default PDF viewer to Adobe Acrobat, or you could skip using the PDF Preview option in APT and use APT's "File>Export>Export PDF to Proposal Directory". The latter option does not use your default PDF viewer.

APT does not allow submission of very large PDF attachments (larger than about 50 MB).

Workaround: If this happens to you please submit without an attachment and contact help@stsci.edu. We will arrange to get your attachment via e-mail. (52887)

Updating an old Phase I Proposal:

Can I open a previous cycle's HST proposal in APT?

Yes, but only if it was written in APT (Cycle 12 was the first to use APT) . Just use Open from the File menu.

I can't find my APT proposal file from last year. How can I get a copy?

Send an email to help@stsci.edu and provide the PI name and Title and we will verify and forward the XML file to you.

How can I get rid of a previous cycle's proposal number?

When you open a proposal which was submitted in a previous cycle you probably will see the proposal number it was submitted under. To clear the old ID simply update the Cycle number on the Proposal Information form.

Phase II:

For general Phase II information see Resources for Phase II Proposal Development

How do I convert my Phase I proposal to Phase II?

Open your Phase I proposal using APT and then click on the Phase I -> Phase II button on the tool bar.If the button is not active, make sure that you have your proposal selected in the hierarchical editor.

Why can't I specify the order of visits in a SEQ WITHIN?

The order of visits of a SEQ WITHIN visit requirement cannot be specified. Instead, APT orders the visits in numerical order. (47683)

Sorting the Spreadsheet editor on Exposure time doesn't change row order.

Clicking on a header generally sorts by that field. But clicking on Exposure Time does not. It toggles the little up/down arrow but does nothing else. (62526)

Orbit Planner:

Why am I asked "to accept incoming network connections" when I run the Orbit Planner?

Because of the way APT communicates with the Orbit Planner engine, you may initially be asked a question like: "Do you want the application "APT.app" to accept incoming network connections?" We recommend that you deny external connections. The system should then remember that answer and not ask you again. Unfortunately some security arrangements (such as the one for Mac at STScI) do no allow the answer to be saved. So you will be reasked this question the first time you run the Orbit Planner in each APT session.

Why is the Orbit Planner failing to run after having run successfully and eventually giving the pop up message: "Orbit Planner server communications failure. Please restart APT and try again."?

This can be due to running the Orbit Planner, becoming disconnected from the internet, reconnecting and then trying to run the Orbit Planner again. Saving the proposal, restarting APT and reopening the proposal should clear up the problem.

Why is the Orbit Planner failing with the message: "Orbit Planner server communication failure" and/or the words "Server Unavailable" appears at the top of the Orbit Planner display?

APT can't communicate with the Orbit Planner server when there is a misconfiguration of a unix machines's network interface (specifically such that its hostname/domain designation does not match its actual IP address). Here are three specific examples that have happened and the fixes. If neither of these examples apply, please generally check your network settings with respect to their hostname and domain.

Case 1a: You are traveling with your linux laptop and your machine's full host name (e.g. mymachine.stsci.edu) is hard coded into the file /etc/sysconfig/network, but you are not currently at your home institution. Try editing the host name to be just one word (e.g. mymachine) while you are away.

Case 1b: Your machine's host name (e.g. mymachine) is hard coded into the file /etc/sysconfig/network, but it still isn't working. Try adding your IP address and host name to the file /etc/hosts.

Case 2: Your linux laptop has an IP address assigned by DHCP, but also has a conflicting IP address defined for its hostname in either /etc/hosts or a Domain Name Server (DNS). So, upon boot-up your laptop is given an IP address from DHCP that differed from the IP address listed in the /etc/hosts or DNS server. To check for this descrepancy do "host mymachine" (which returns mymachines's IP address from DNS) and "/sbin/ifconfig" (which returns the IP address that was assigned to the Ethernet card). Try configuring your laptop to obtain its IP address from either DHCP or DNS, not both.

Why is the Orbit Planner slow while on VPN?

This started after the move to Java 7. This has been reported by three people at STScI and one person at Goddard. We have made one fix (in APT 22.2) that helps the Orbit Planner start faster, but it is still slower to run once it starts. In order to use this fix you have to select the APT HST Preference called "Orbit Planner forces local communication". If processing speed is still an issue the workaround is to turn off VPN while using the Orbit Planner. (77010)

Visit Planner:

Inconsistent scheduling results for Orientation restrictions with the Visit Planner.

If you are noticing an inconsistency between Phase I and Phase II it could be due to a Phase I Visit Planner bug in APT 22.0 and 22.0.1. The fix for this bug would also explain an inconsistency between scheduling results seen in APT 22.0/22.0.1 and APT 22.0.2/22.2. (77479)

There are "casm.exe" processes running even after quitting APT.

Workaround: If you notice a stranded "casm" process when APT is not running, manually stop it using 'kill -9' (or Stop Process in the Window Task Manager). (71649)

The Visit Planner will occasionally continue to display a deleted visit.

Workaround: The deleted visits will go away the next time you save, close, and reopen the proposal. (48093)

Aladin:

Why is Aladin very slow to make modifications on my linux machine?

Some linux users have reported very poor responsiveness from Aladin when moving/rotating apertures. We believe that this is due to where linux is doing transparency calculations (on the graphics card or in Java itself). Workaround: Go to Edit>User Preference in Aladin and deactivate Aladin's Transparency/opacity option. (63842)

Aladin is not properly displaying my mosaic in Phase I.

If you have Aladin up prior to creating or revising a mosaic in Phase I, the Aladin display will not recognize the change. (76742)

Workaround: In order to force Aladin to see the change, with Aladin selected as the APT tool, click in the APT GUI and use the APT menu: View in Aladin > Aladin Display > Refresh Aladin.

BOT:

Does the BOT take both Orient and Pos Targ into account?

If an exposure has a POS TARG, and its visit has an ORIENT, the BOT only sometimes takes the Orient into account when it processes the exposure. If the Pos Targ is small, where small is defined as half the size of the aperture (e.g. for a 52" STIS slit, 21"), then the Orient is ignored (in other words all Orients are considered). If the Pos Targ is large, then the Orient is taken into account when processing the exposure.